Thursday, August 13, 2009

Using msb430 devices with contiki-2.x



Installing gcc-msb430:
Added following line to the file /etc/apt/sources.list
deb http://wyper.ca/debian i686/
Then run:
apt-get update
apt-get install binutils-msp430 gcc-msp430 msp430-libc msp430-jtag

-------------------------------------------------------------------
Burning apps:
Change ownership of /dev/parport0
chmod o+rw /dev/parport0
Compile and burn application
make TARGET=msb430 <appname>.u

Note: Here appname is your application name msb430 is the device
platform '.u' denote that it should be uploaded (burned) to the
device.

1 comment:

  1. Thank you for the post aiya..
    But I have a problem. I Followed all the steps. But When I try to burn the application to the device(msb430) it gives me the following error.

    Can't open interface
    make: *** blink.u error 1

    What might be the problem?

    ReplyDelete